Issue with deployed instances in EU region

Incident Report for PowerSync

Resolved

The issue has been fully resolved. We will implement preventive measures to ensure this does not recur in the future.
Posted Dec 23, 2025 - 13:01 UTC

Monitoring

A fix has been implemented at our upstream storage provider and we are monitoring the results.
Posted Dec 22, 2025 - 22:38 UTC

Update

We seem to have encountered an issue with our upstream storage provider and are working with their support team on implementing a resolution. We have escalated the issue with their team. They have acknowledged the escalation and are currently working the issue.

We will continue to provide updates as soon as we have them.
Posted Dec 22, 2025 - 20:13 UTC

Identified

We've identified an issue with the storage in our EU region and are currently waiting for a fix to be applied.
Posted Dec 22, 2025 - 18:31 UTC

Investigating

Our systems have alerted us to an issue in our EU region. Replication lag for some deployed instances is increasing as a result of this issue.

We are currently investigating the customer impact and will keep this incident up to date.
Posted Dec 22, 2025 - 18:08 UTC
This incident affected: PowerSync Service - EU Cluster.