Potential connectivity issues

Incident Report for PowerSync

Resolved

Our upstream storage provider has identified and repaired the issue in the affected cluster.
Posted Jul 28, 2026 - 06:25 UTC

Identified

We have identified a potential issue with an upstream storage provider. Our team have opened a support ticket with them to confirm.

Currently connected sync clients will likely continue syncing, but it's possible that new clients will be unable to sync.
Posted Jul 28, 2026 - 03:49 UTC

Investigating

We've identified a potential issue with some instances in our US cluster. Our team are currently investigating.
Posted Jul 28, 2026 - 03:29 UTC
This incident affected: PowerSync Service - US Cluster.