Unable to deploy newly created instances in US region

Incident Report for PowerSync

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 03:32 UTC

Identified

We've identified an issue in our US Cluster where newly created instances can not be deployed from the dashboard.

Existing instances are unaffected and remain operational. Deployments to existing instances are also unaffected.

We have identified the root cause and are investigating a fix.
Posted Apr 08, 2026 - 02:02 UTC
This incident affected: PowerSync Service - US Cluster.