Issue Affecting New Signups

Incident Report for PowerSync

Resolved

This incident has been resolved.
Posted Aug 09, 2025 - 21:51 UTC

Monitoring

Signups are working again and we're monitoring the status.
Posted Aug 09, 2025 - 17:58 UTC

Investigating

New users are currently unable to signup for PowerSync Cloud. We are investigating the issue.
Posted Aug 09, 2025 - 17:25 UTC
This incident affected: Dashboard.